Calibre OPDS doesn't work when login details are required

  • Version 2.70
  • Tested on iPhone XS Max and iPad Pro 12.9" 2nd Gen
  • iOS 15 Dev Beta 5
  • Using a new library with Calibre 5.24

When attempting to connect to a Calibre OPDS server it will ONLY work if login credentials aren’t required by the content server.

  • Panels doesn’t use the credentials even if you enter a Username and Password (tested this by creating login details that only access certain parts of a library).

  • When you set the Calibre content server to only accept connections with login credentials, Panels fails to connect to it.

My guess is that Panels is expecting an HTTPS connection when Calibre isn’t. I also use Yomu for books and the connection there works with http:// but NOT https://. When attempting to connect with https:// the following error is found in the Calibre content server logs:

Screenshot 2021-08-13 at 04.40.34

When http:// is used however Panels fails to even find the server, whereas with https:// Panels does find but fails to connect to the server.

Thanks for the report. We’ll try to reproduce it and fix it.

Nevertheless, Panels won’t connect to any non-secure domain due to an iOS security feature called Apple Transport Security (ATS) https://developer.apple.com/documentation/security/preventing_insecure_network_connections

We’ve disabled ATS for IP and local network connections, but domain-name-based configurations require a secure connection over HTTPS.

But failing to authenticate over HTTPS sound like a separate issue.

Thanks for the clarification, I should have mentioned though that the connection fails over a local network, I have not configured my library to work over the internet. Im never sure whether HTTP or HTTPS is the right thing to use when typing in my details so apologies for the confusing language.

1 Like

I have the same problem, I cannot connect to my caliber library over a local network.

Do you have a “step by step” to configure Caliber OPDS in Panels through a local collection?